server.url config variable doesn't work on password reset

LogicalDOC has many interesting features, but requires some configuration process to show its full potential.

Moderators: car031, car031, car031

Locked
jormatuomainen
Posts: 4
Joined: Mon Jun 27, 2016 1:06 pm

server.url config variable doesn't work on password reset

Post by jormatuomainen » Mon Jun 27, 2016 2:06 pm

Hi,

I have instance of LogicalDoc CE behind nginx as reverse proxy (doing TLS termination).
So it's https://docs.domain.tld/ (default 443 port), tomcat itself is running on localhost:8080.
server.url is configured as https://my_server/
some how password links are in form of http://docs.domain.tld:80/pswrecovery?ticketId...

I did restart tomcat, even removed work and temp and restarted, still no effect.

Should the part of $url in email templates come from server.url?

car031
Posts: 144
Joined: Tue Apr 17, 2012 8:27 am

Re: server.url config variable doesn't work on password rese

Post by car031 » Tue Jun 28, 2016 10:46 am

Hi, but in case of password recover that parameter must not be used. We imagine that the user is in the GUI and forgot the password, he ask for the reset and he immediately receive a message in his email. Now the URL must be the same he is seing in the browser, independently from the url you specifed in server.url.

jormatuomainen
Posts: 4
Joined: Mon Jun 27, 2016 1:06 pm

Re: server.url config variable doesn't work on password rese

Post by jormatuomainen » Tue Jun 28, 2016 10:55 am

The link should use the same (https://docs.domain.tld/) but it doesn't. It changes protocol to http and port to 80.

So it uses neither the server.url (which it should), nor the localhost:8080 (which the reverse proxy connects) nor the https (default port 443) that the client browser connects. It's specified as $url in the email templates but where does it get the value? I did of course did unsecure hack to forward http to https with get params, but it's not exactly a good solution, do you have a better one?

car031
Posts: 144
Joined: Tue Apr 17, 2012 8:27 am

Re: server.url config variable doesn't work on password rese

Post by car031 » Tue Jun 28, 2016 11:07 am

for that messate $url is computed dynamically and the current URL you see in the browser is used, but the scheme and port should be correctly replicated.
What version of LogicalDOC are you using ?

jormatuomainen
Posts: 4
Joined: Mon Jun 27, 2016 1:06 pm

Re: server.url config variable doesn't work on password rese

Post by jormatuomainen » Tue Jun 28, 2016 5:05 pm

7.4.3 community edition, but I do have the nginx in front of it doing the ssl termination (I can't figure out the 80 port though, that is not used).

car031
Posts: 144
Joined: Tue Apr 17, 2012 8:27 am

Re: server.url config variable doesn't work on password rese

Post by car031 » Tue Jun 28, 2016 5:31 pm

tried on a 7.5 and the URL is correct-

jormatuomainen
Posts: 4
Joined: Mon Jun 27, 2016 1:06 pm

Re: server.url config variable doesn't work on password rese

Post by jormatuomainen » Tue Jun 28, 2016 8:11 pm

Ok, I'll try updating soon.

Locked

Who is online

Users browsing this forum: No registered users and 1 guest