CE 7.5 Access Denied after Restart Server

LogicalDOC has many interesting features, but requires some configuration process to show its full potential.

Moderator: car031

Locked
hanspeter
Posts: 9
Joined: Wed Jul 06, 2016 8:12 am

CE 7.5 Access Denied after Restart Server

Post by hanspeter » Wed Aug 03, 2016 2:45 pm

hi,
i made a system restart after updates (ubuntu 14.04, java 1.8.0_101) and now i have troubles to login to my instance.

I get always an "Access Denied", with ever user.

localhost_access_log:

Code: Select all

172.16.24.254 - - [03/Aug/2016:15:23:07 +0200] "POST /logicaldoc/j_spring_security_check HTTP/1.1" 302 -
172.16.24.254 - - [03/Aug/2016:15:23:07 +0200] "GET /logicaldoc/?failure=notfound HTTP/1.1" 302 -
172.16.24.254 - - [03/Aug/2016:15:23:08 +0200] "GET /logicaldoc/login.jsp?failure=notfound HTTP/1.1" 200 3563
172.16.24.254 - - [03/Aug/2016:15:23:08 +0200] "POST /logicaldoc/login/login HTTP/1.1" 200 408
what is j_spring_security_check?
thanks for help.

car031
Posts: 154
Joined: Tue Apr 17, 2012 8:27 am

Re: CE 7.5 Access Denied after Restart Server

Post by car031 » Wed Aug 03, 2016 3:26 pm

the accesslog is not helpful.

You should look at the application logs at repository/logs/dms.log

hanspeter
Posts: 9
Joined: Wed Jul 06, 2016 8:12 am

Re: CE 7.5 Access Denied after Restart Server

Post by hanspeter » Wed Aug 03, 2016 3:42 pm

ok, the application log says:

Code: Select all

03.08.2016 16:20:15,501 WARN   (com.logicaldoc.core.security.spring.LDAuthenticationProvider:  83) -- Username  not found
03.08.2016 16:20:45,667 WARN   (com.logicaldoc.core.security.spring.LDAuthenticationProvider:  83) -- Username  not found
03.08.2016 16:23:12,117 WARN   (com.logicaldoc.core.security.spring.LDAuthenticationProvider:  83) -- Username  not found
03.08.2016 16:23:20,371 WARN   (com.logicaldoc.core.security.spring.LDAuthenticationProvider:  83) -- Username  not found
i tried admin and my username.
i checked the mysql table 'ld_user', admin and my username are there...
?

car031
Posts: 154
Joined: Tue Apr 17, 2012 8:27 am

Re: CE 7.5 Access Denied after Restart Server

Post by car031 » Wed Aug 03, 2016 4:14 pm

perhaps the databae is not connected properly or parhaps you ahve more than one context.properties in your classpath and it is taking a wrong one

hanspeter
Posts: 9
Joined: Wed Jul 06, 2016 8:12 am

Re: CE 7.5 Access Denied after Restart Server

Post by hanspeter » Mon Aug 08, 2016 1:38 pm

thanks for reply,
database connection was ok, there was only one context.properties in path and the content seemed to be ok.

Finally, i cleaned up the directory, extract the zip again and started web-setup again. Connect to my database was successful and i moved back the content of my data folder.

Now my server is up and running, i hope the best for the next update cycle :)

thread can be closed.

Locked

Who is online

Users browsing this forum: Bing [Bot] and 1 guest