Documents default location

LogicalDOC has many interesting features, but requires some configuration process to show its full potential.

Moderator: car031

Locked
plevko77
Posts: 9
Joined: Tue Apr 04, 2017 2:49 am

Documents default location

Post by plevko77 » Fri Apr 21, 2017 7:51 pm

Is there a way to change default path where documents are saved? When I click on the default hyperlink under settings get 404 not found error.

Thanks

Jerry :|

agaspa
Posts: 514
Joined: Tue Apr 20, 2010 8:24 am

Re: Documents default location

Post by agaspa » Fri Apr 28, 2017 10:28 am

Hi plevko77,
which version of LogicalDOC CE you're running?
Perhaps there is an error in the GUI, but of course you can always change the parameters in the general config. file (context.properties)

Follow this procedure:
1) Shutdown LogicalDOC (or tomcat service)
2) Locate the file context.properties under /<LD_INSTALL_DIR>/conf
3) edit that file by changing the value for key store.1.dir
4) save the file and restart LD

(See the attached image [LD CE 7.6.4])
document-store-path.gif
config file of LD CE 7.6.4 (Windows)
document-store-path.gif (30.16 KiB) Viewed 632 times

plevko77
Posts: 9
Joined: Tue Apr 04, 2017 2:49 am

Re: Documents default location

Post by plevko77 » Sun Apr 30, 2017 5:52 pm

I am using 7.6.4.

car031
Posts: 144
Joined: Tue Apr 17, 2012 8:27 am

Re: Documents default location

Post by car031 » Mon May 01, 2017 7:18 am

ok the store.1.dir property is correct in your case

plevko77
Posts: 9
Joined: Tue Apr 04, 2017 2:49 am

Re: Documents default location

Post by plevko77 » Mon May 01, 2017 9:30 pm

I did tried this and no go. It will not create new dir under my new folder. Also would this work with UPN path? Let say I have NAS \\NAS-buffalo\Documents\LogicalDocs\

When attempted to save document after I modified that store.1 setting was getting error that document cannot be saved to the server or some kind of message.

plevko77
Posts: 9
Joined: Tue Apr 04, 2017 2:49 am

Re: Documents default location

Post by plevko77 » Tue May 02, 2017 4:01 am

I have mapped X drive to my nas and created shares LogicalDocs\repository\docs
Edited line to be like this :
store.1.dir=X\:\\LogicalDocs/repository/docs

When try to copy file there get error Exception: Unable to store document file.

I am assuming that syntax I have used it't wrong as I don't see anything created there.

car031
Posts: 144
Joined: Tue Apr 17, 2012 8:27 am

Re: Documents default location

Post by car031 » Tue May 02, 2017 7:07 am

you cannot use 'mapped drives' in a java application. You have to use the UNC path, that is simething like //NAS-buffalo/Documents/LogicalDocs

plevko77
Posts: 9
Joined: Tue Apr 04, 2017 2:49 am

Re: Documents default location

Post by plevko77 » Wed May 03, 2017 8:12 pm

I have tried all combinations could think of nothing worked with UNC path.
What will be the syntax there as I noticed C \: at beginning which is the C root.

car031
Posts: 144
Joined: Tue Apr 17, 2012 8:27 am

Re: Documents default location

Post by car031 » Thu May 04, 2017 6:46 am


plevko77
Posts: 9
Joined: Tue Apr 04, 2017 2:49 am

Re: Documents default location

Post by plevko77 » Thu May 04, 2017 8:11 pm

Thanks that point me to right direction. Issue was with the authentication enable on the folder. Removed it and it saved to NAS drive.

Thanks

Locked

Who is online

Users browsing this forum: No registered users and 1 guest