Install on Ubuntu 18.04 Turns Out tobe the Wrong Version

Problems with installing LogicalDOC? No problems, the solution is closer than you think.

Moderator: car031

Datsys100
Posts: 9
Joined: Sat Jun 24, 2017 4:45 am

Install on Ubuntu 18.04 Turns Out tobe the Wrong Version

Mon Jul 13, 2020 1:44 am

Howdy All,
I am hoping that this post is in the right place. If not then I hope it can be put where it belongs.

So I followed this tutorial (https://computingforgeeks.com/how-to-in ... 18-04-lts/) to install LogicalDOC on my server using Ubuntu 18.04. I made some changes like from Java 11 to 14 and LD 8.4 to 8.5 so as to ensure I am working with current software. It seems to have gone almost perfectly until I tried to login from the web interface for the first time. Here I found that I am running the Enterprise version of LD not the Community Edition and the admin/admin credentials required for first sign on is not working. I am also seeing a message about invalid license.

Did I download the wrong version or missed something in the install that would have switched it to CE? How do I fix both (first sign in credentials do not work & use the CE version instead of the Enterprise) problems? Not affraid to wipe the machine and start from scratch if I have to.
shayan.rahat
Posts: 1
Joined: Wed Sep 02, 2020 12:02 pm

Re: Install on Ubuntu 18.04 Turns Out tobe the Wrong Version

Wed Sep 02, 2020 12:23 pm

Hi Datsys100

Though your post is somewhat dated, I've been wrestling with similar issues the past couple of days, relying on the same link as the one you've referenced (using Ubuntu 20.04 LTS in my case).
So, I have, I think, overcome the problem you've referred to in your post regarding the installer being the wrong version. You are right. The Community Edition is not linked to by the article. As of this writing, the correct link for the latest Community Edition installer (GNU/Linux that is) is here on sourceforge.
I'm not sure if you've already found the solution, given the time since your posting. But as no one had posted a reply, where I may have had a chance to find an answer to a problem that cropped up later, I'm replying to your post. I should just mention that instead of running the installer with bash, you'd have to run this one using

Code: Select all

sudo java -jar logicaldoc-installer.jar
as it's a jar file.
So, continuing the installation procedure with the correct installer got me past the "Access Denied" problem. But I've run into a new problem which has proved to be more stubborn. Once logged in, whenever I try to upload the very first file into LogicalDoc, I get an error saying
Exception: Unable to store the file of document.
I've searched quite a bit in order to find an answer to this question. At first, I wound up in here as I was running things in an ESX virtual machine and I saw some logs that I googled which led me there. I tried their solution, yet nothing changed. I even went through the whole different installation on a proxmox virtual machine to test if it would help to no avail.
So, I was wondering if you have gone on to run into the same problem and, hopefully, found a solution. Any news on your installation?
Anyone else here who may have faced and solved this problem?

Regards,
Shayan

Return to “Installation”

Who is online

Users browsing this forum: No registered users and 1 guest