Build error of LogicalDOC6.0 CE src Ver.

Problems with installing LogicalDOC? No problems, the solution is closer than you think.

Moderator: car031

leekof98
Posts: 17
Joined: Thu Feb 24, 2011 7:03 am

Build error of LogicalDOC6.0 CE src Ver.

Tue Mar 01, 2011 7:57 am

Hello agaspa and everybody!

In the README of the CE src Ver,
It says that 'You need JDK 1.6, Maven 2.2.x, Ant 1.7 to build this sources'
But I still failed to build it after intalling the software required...
build error.JPG
error message
build error.JPG (95.31 KiB) Viewed 1974 times
Error message said that maven-3.0 required,
And I tried to build it with the latest Ver of the softwares (ant-1.8.2 & maven-3.0.2)
But failed,too ...

Can someone help with that ?
thanks

lee
agaspa
Posts: 709
Joined: Tue Apr 20, 2010 8:24 am

Re: Build error of LogicalDOC6.0 CE src Ver.

Tue Mar 01, 2011 9:33 am

Hi lee,
you are right, in order to build LogicalDOC 6.0.1 from sources you need Maven 3.0.x (we forgot to update the readme)
and also you need Ant 1.7.x and JDK 1.6.x.
Another important component that you need for the release 6.0.1 is GWT 2.1.1
Please let us know if you encounter other problems attaching a printout of your attempt to build
You can redirect the output of maven to a file
mvn clean install > out.txt

Return to “Installation”

Who is online

Users browsing this forum: No registered users and 1 guest