upgrade 6.0.1 to 6.1

Problems with installing LogicalDOC? No problems, the solution is closer than you think.

Moderator: car031

stefan.liv
Posts: 5
Joined: Fri Apr 08, 2011 4:22 pm

upgrade 6.0.1 to 6.1

Fri Apr 08, 2011 4:33 pm

Hi,

I have a logicaldoc CE 6.0.1 running.
What is the best way to upgrade this to version 6.1?

I tried some things, like installing 6.1 and copying over the whole repository, but it doesn't work that way.

ps: thanks for this wonderfull product!!
agaspa
Posts: 709
Joined: Tue Apr 20, 2010 8:24 am

Re: upgrade 6.0.1 to 6.1

Fri Apr 08, 2011 5:12 pm

The upgrade for the Open Source (Community edition) of LogicalDOC 6.1 will be released when the commercial edition 6.2 will be released.

However there are no particular changes, only small updates in the schema of the database.

So if you want to upgrade your LD CE 6.0.x to 6.1 it will be sufficient:

1) apply the changes to the database
2) install the new version of the program
3) merge your old context.properties file (which contains your Settings)

I recommend this as a hint: compare the 2 version of file logicaldoc-core.sql which you can find in the src distribs. of the software

Also read this guide: http://wiki.logicaldoc.com/wiki/LDCE_Mi ... 0_to_6.0.1

Have fun :geek:
Alex
stefan.liv
Posts: 5
Joined: Fri Apr 08, 2011 4:22 pm

Re: upgrade 6.0.1 to 6.1

Mon Apr 11, 2011 4:46 pm

Thanks for your answer.

Another thing: how do I do step 1 with the "inbuilt" db?
agaspa
Posts: 709
Joined: Tue Apr 20, 2010 8:24 am

Re: upgrade 6.0.1 to 6.1

Tue Apr 12, 2011 10:34 am

Shutdown the Tomcat that runs LogicalDOC and open the DB with SQuirrel SQL http://www.squirrelsql.org/
Connect to the db of LD which is located in the LD working dir, then you can apply the opportune changes to the DB.
Disconnect from the DB
Exit from SQuirrel SQL Client
Restart LogicalDOC
(this procedure is needed because HSQLDB is a Java embedded DB and you can use it from only one JVM concurrently)

Have a nice day
Alex
stefan.liv
Posts: 5
Joined: Fri Apr 08, 2011 4:22 pm

Re: upgrade 6.0.1 to 6.1

Thu Jul 07, 2011 2:56 pm

Hello again,

Only now I'm back on the project where we used logicalDOC 6.0.1.
And I found the "upgrade tools" to do the upgrade from sourceforge.
Unfortunately the sql doesn't run on my squirrelsql. I get lots of errors executing the sql.

example:
alter table ld_document add column ld_barcoded int not null default 2;
-> squirrelsql doesn't like the "not null"
alter table ld_document modify ld_customid VARCHAR(255);
-> squirrelsql: Unexpected token: MODIFY in statement [alter table ld_document modify]
alter table ld_ticket drop FOREIGN KEY FK_TICKET_DOC;
-> squirrelsql: Column not found: FOREIGN in statement [alter table ld_ticket drop FOREIGN]

Is this normal? Or linked to my environment? (squirrelsql 3.2.1)

Thanks for your time
mmeschieri
Posts: 242
Joined: Mon Apr 19, 2010 3:40 pm

Re: upgrade 6.0.1 to 6.1

Sat Jul 09, 2011 9:28 am

For the not null, you can remove it and reexecute the instruction.

For the other errors, these statements was written for MySQL you should write the same command but using your DB syntax.

Regards
stefan.liv
Posts: 5
Joined: Fri Apr 08, 2011 4:22 pm

Re: upgrade 6.0.1 to 6.1

Mon Jul 11, 2011 5:19 pm

Ah thanks for the explanation.
I thought the sql was for the HSQLDB used as internal db for logicaldoc, so now I know I should adapt it.

Stefan

Return to “Installation”

Who is online

Users browsing this forum: No registered users and 1 guest