Error while compiling LogicalDoc Community 6.2

Problems with installing LogicalDOC? No problems, the solution is closer than you think.

Moderator: car031

valar
Posts: 2
Joined: Thu Jun 23, 2011 3:12 pm

Error while compiling LogicalDoc Community 6.2

Thu Jun 23, 2011 3:22 pm

Hi!
I have troubles compiling LDC 6.2 with Apache Maven 3.0.3, Java version: 1.6.0_25 on linux version: 2.6.37.1-1.2-desktop x64.

Executing:
mvn install
I got:
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 0.646s
[INFO] Finished at: Thu Jun 23 09:19:06 CDT 2011
[INFO] Final Memory: 3M/54M
[INFO] ------------------------------------------------------------------------

Executing:
localhost:~/src/community/logicaldoc # mvn -Dmaven.test.skip=true install
I got:
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO]
[INFO] logicaldoc ........................................ SUCCESS [0.214s]
[INFO] logicaldoc-util ................................... SUCCESS [1.819s]
[INFO] logicaldoc-i18n ................................... SUCCESS [0.095s]
[INFO] logicaldoc-core ................................... FAILURE [2.793s]
[INFO] logicaldoc-webservice ............................. SKIPPED
[INFO] logicaldoc-webdav ................................. SKIPPED
[INFO] logicaldoc-gui .................................... SKIPPED
[INFO] logicaldoc-webapp ................................. SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 5.608s
[ERROR] Failed to execute goal on project logicaldoc-core: Could not resolve dep
endencies for project com.logicaldoc:logicaldoc-core:jar:6.2.0: Failed to collec
t dependencies for [javax.activation:activation:jar:1.1.1 (provided), commons-lo
gging:commons-logging:jar:1.1.1 (provided), commons-collections:commons-collecti
ons:jar:3.2 (compile), org.apache.ant:ant:jar:1.7.0 (provided), antlr:antlr:jar:
2.7.7 (provided), betelio:betelio:jar:1.0 (provided), commons-validator:commons-
validator:jar:1.3.1 (provided), commons-el:commons-el:jar:1.0 (provided), common
s-discovery:commons-discovery:jar:0.4 (provided), commons-lang:commons-lang:jar:
2.4 (provided), commons-dbcp:commons-dbcp:jar:1.4 (provided), commons-io:commons
-io:jar:1.4 (provided), commons-pool:commons-pool:jar:1.5.4 (provided), commons-
httpclient:commons-httpclient:jar:3.1 (compile), commons-codec:commons-codec:jar
:1.2 (runtime), hsqldb:hsqldb:jar:1.8.1.3 (provided), xml-apis:xml-apis:jar:1.3.
04 (provided), xerces:xercesImpl:jar:2.8.1 (provided), jdom:jdom:jar:1.0 (provid
ed), log4j:log4j:jar:1.2.15 (provided), oro:oro:jar:2.0.8 (provided), org.apache
.poi:poi:jar:3.7 (compile), org.apache.poi:poi-scratchpad:jar:3.7 (compile), jav
ax.mail:mail:jar:1.4.1 (provided), org.springframework:spring-core:jar:3.0.4.REL
EASE (provided), org.springframework:spring-jdbc:jar:3.0.4.RELEASE (provided), o
rg.springframework:spring-orm:jar:3.0.4.RELEASE (provided), org.springframework:
spring-context-support:jar:3.0.4.RELEASE (provided), org.hibernate:hibernate-cor
e:jar:3.3.2.GA (provided), org.hibernate:hibernate-ehcache:jar:3.3.2.GA (compile
), org.slf4j:slf4j-api:jar:1.5.8 (provided), org.slf4j:slf4j-log4j12:jar:1.5.8 (
provided), org.quartz-scheduler:quartz:jar:1.8.3 (compile), net.sourceforge.neko
html:nekohtml:jar:1.9.7 (compile), javax.transaction:jta:jar:1.1 (provided), jun
it:junit:jar:4.4 (provided), net.sf.jpf:jpf-boot:jar:1.5.1 (provided), net.sf.jp
f:jpf:jar:1.5.1 (provided), jakarta-regexp:jakarta-regexp:jar:1.4 (provided), co
m.logicaldoc:logicaldoc-util:jar:6.2.0 (provided), com.logicaldoc:logicaldoc-i18
n:jar:6.2.0 (provided), org.apache.pdfbox:pdfbox:jar:1.5.0 (compile), com.ibm.ic
u:icu4j:jar:3.8 (compile), org.apache.lucene:lucene-core:jar:3.1.0 (compile), or
g.apache.lucene:lucene-highlighter:jar:3.1.0 (compile), org.apache.lucene:lucene
-misc:jar:3.1.0 (compile), org.apache.lucene:lucene-analyzers:jar:3.1.0 (compile
), org.apache.lucene:lucene-memory:jar:3.1.0 (compile), jmimemagic:jmimemagic:ja
r:0.1.2 (compile), org.hyperic.sigar:sigar:jar:1.6.3 (provided), org.icepdf:icep
df-core:jar:4.2.0 (compile), javax.media:jai-core:jar:1.1.3 (compile), com.sun.m
edia:jai-codec:jar:1.1.3 (compile)]: Failed to read artifact descriptor for com.
sun.media:jai-codec:jar:1.1.3: Could not transfer artifact com.sun.media:jai-cod
ec:pom:1.1.3 from/to jboss (http://repository.jboss.com/maven2): Access denied t
o: http://repository.jboss.com/maven2/com/ ... ai-codec-1.
1.3.pom -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please rea d the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/disp ... nException
[ERROR]
[ERROR] After correcting the problems, you can resume the build with the command
[ERROR] mvn <goals> -rf :logicaldoc-core

Any Idea why this happening this???

Thanks for any advice!
mmeschieri
Posts: 242
Joined: Mon Apr 19, 2010 3:40 pm

Re: Error while compiling LogicalDoc Community 6.2

Sun Jun 26, 2011 8:21 pm

You don't have all the dependencies and maven was not able to download all the resources. I see access denied from the JBoss repository, check the accessibility of all the declared repositories.
valar
Posts: 2
Joined: Thu Jun 23, 2011 3:12 pm

Re: Error while compiling LogicalDoc Community 6.2

Tue Jun 28, 2011 5:01 pm

mmeschieri wrote:You don't have all the dependencies and maven was not able to download all the resources. I see access denied from the JBoss repository, check the accessibility of all the declared repositories.
Yes, thats the problem... the repository don't allo the access to download the dependences. The next question is: how can I get access in the repository to resolve this?

Thanks again!
gelmetti.matteo
Posts: 5
Joined: Fri Aug 05, 2011 3:48 pm

Re: Error while compiling LogicalDoc Community 6.2

Mon Aug 08, 2011 12:57 pm

I got a similar error trying to connect to "http://repository.jboss.org/maven2/java ... -1.1.3.jar"
Even if i try directly from the browser i got a FORBIDDEN error.
Can anyone help me fix this problem and complete my compilation successfully???

Thank you
Teo

[ERROR] Failed to execute goal on project logicaldoc-core: Could not resolve dep
endencies for project com.logicaldoc:logicaldoc-core:jar:6.2.1: The following ar
tifacts could not be resolved: javax.media:jai-core:jar:1.1.3, com.sun.media:jai
-codec:jar:1.1.3: Could not transfer artifact javax.media:jai-core:jar:1.1.3 fro
m/to jboss (http://repository.jboss.com/maven2): Access denied to: http://reposi
tory.jboss.com/maven2/javax/media/jai-core/1.1.3/jai-core-1.1.3.jar -> [Help 1]
[ERROR]
agaspa
Posts: 709
Joined: Tue Apr 20, 2010 8:24 am

Re: Error while compiling LogicalDoc Community 6.2

Wed Sep 28, 2011 10:43 am

You can add this repository to your maven logicaldoc-parent-pom

http://repository.jboss.org/nexus/conte ... dec/1.1.3/

The parent pom is the file named pom.xml in the source distro of LD CE
in folder: logicaldoc-6.2.4-src\build\poms

See the attached image

Then you must reinstall the parent pom
Attachments
logicaldoc-parent-pom.gif
LogicalDOC parent pom in src distribution
logicaldoc-parent-pom.gif (43.15 KiB) Viewed 7487 times
rahulwagh
Posts: 1
Joined: Thu Apr 26, 2012 8:02 am

Re: Error while compiling LogicalDoc Community 6.2

Thu Apr 26, 2012 8:28 am

https://maven2-repository.dev.java.net/nonav/repository

this url is not exits...what should i do...what changes i should make in pom.xml....at the time of compilation,it gives following error ....

[ERROR] Failed to execute goal on project logicaldoc-core: Could not resolve dep
endencies for project com.logicaldoc:logicaldoc-core:jar:6.4.0: The following ar
tifacts could not be resolved: javax.jms:jms:jar:1.1, javax.media:jai-core:jar:1
.1.3, com.sun.media:jai-codec:jar:1.1.3: Could not transfer artifact javax.jms:j
ms:jar:1.1 from/to java.net (https://maven-repository.dev.java.net/nonav/reposit
ory): No connector available to access repository java.net (https://maven-reposi
tory.dev.java.net/nonav/repository) of type legacy using the available factories
WagonRepositoryConnectorFactory -> [Help 1]

Plz help.....
ssalazar
Posts: 1
Joined: Fri Jun 29, 2012 4:45 pm

Re: Error while compiling LogicalDoc Community 6.2

Fri Jun 29, 2012 5:51 pm

I solved the problem by adding this:

<repository>
<id>repository.jboss.org-public</id>
<name>JBoss repository</name>
<url>https://repository.jboss.org/nexus/cont ... ublic</url>
</repository>
after line 112 of community/logicaldoc/pom.xml

Then I changed line 23 community/logicaldoc/logicaldoc-webdav/pom.xml to 1.0 (in the ibiblio repository don't has the 1.0.1 jar, but has the 1.0.1 sources)


PD: Sorry my bad English, I'm not a native speaker

Return to “Installation”

Who is online

Users browsing this forum: No registered users and 1 guest