WebDav Bug

Problems with installing LogicalDOC? No problems, the solution is closer than you think.

Moderator: car031

Posts: 6
Joined: Wed Aug 24, 2011 2:49 pm

WebDav Bug

Thu Nov 10, 2011 10:05 pm

I've been having quite the same problems getting the WebDav-Protocol running as some other people reporting this incident in this forum. It took me this whole worthless day to finally hunt this problem down and let me tell you this right away: it's not the client that are the root cause of this (even though, you LogicalDoc guys constantly refer to this might be the problem - it just isn't!). Furthermore, this problem seems to be around in many earlier versions but is NOT happening every install. From about 30 different installations of LogicalDoc during this day at least five or six of them have been working fine indeed!

Well, what I've done:

- Tried out every combination of logicaldoc-webdav-plugin and the jackrabbit-webdav possible (even though the jackrabbit one didn't seem to have changed at all - i just wanted to be sure) up from version 6.1 of LogicalDoc with your recently released 6.3
- Tried out various manual Tomcat variations with each LogicalDoc release up from version 6.1
- Tried many older version of Debian's davfs2-package and compiled some of them myself, too
- Tried out cadaver, fusedav, Netdrive et cetera pp.

Nearly nothing was working out as expected and if it did work out well, I didn't know why. The result was always the same while analyzing the cleartext communication betweens the servers webdav implementation and the different clients: 502 - PROPFIND NOT IMPLEMENTED.

So I was wondering about how WebDav is being used in connection with Tomcat at all and while googling a bit around, I got a hold things that need to be done in the deployed applications web.xml for WebDav going down to work.

I opened the logicaldoc/WEB-INF/web.xml file just for fun, did a simple search for 'dav' and oh my... Noting?! Googled further and finally, after a bit of fiddling around, I came up with this:

Code: Select all

Heck yeah, there we go!

And before you're going to ask, yes: I did make sure that in all of my around 30 test and debug installations that LogicalDocs Webdav-service was indeed enabled. I saved every config more than I can count and restarted the whole thing (and each component itself, too) more than a couple of hundred times. Being into computer-science for more than 20 years now, I know how to use that b*tchy little machine besides my legs - even though, I'm not really into Java and / or Tomcat and such things at all. I develop things mainly in C and Objective-C. However, checking the catalina.out it was telling me all the time:

Code: Select all

manifestURL: jar:file:/opt/logicaldoc/tomcat/webapps/logicaldoc/WEB-INF/lib/logicaldoc-webdav-6.3.0-plugin.jar!/plugin.xml
plugin located: logicaldoc-webdav @ jar:file:/opt/logicaldoc/tomcat/webapps/logicaldoc/WEB-INF/lib/logicaldoc-webdav-6.3.0-plugin.jar!/plugin.xml
Intialising plugin: {PluginDescriptor: uid=logicaldoc-webdav@6.3.0}
plugin located: jar:file:/opt/logicaldoc/tomcat/webapps/logicaldoc/WEB-INF/lib/logicaldoc-webdav-6.3.0-plugin.jar!/plugin.xml
Activated plugin logicaldoc-webdav
Another guy in here said that when he was trying out the 'enterprise' trial, the problem didn't occure. I can at least confirm that - the enterprise edition is not suffering from this bug. Hoever, the CE definately is. I'm sorry that I can't debug this any further for you guys. My time's short.

Furthermore: I believe it was Mr. Meschieri that was saying somewhere in this forum, that 'Cadaver' is none of the approved clients however, you guys call it a 'great WebDav' client and explain how to use it in your own Wiki. Something like that is just confusing to be honest!

Anyway, I hope you guys won't be kicking me out of this forum for my 'kind of criticism' known as 'bug-calling' as you did with Mr. Sonnabend ;) I actually do think that LogicalDoc is one of the better DMS out there. I do also think, however, that there are a couple of things that you guys should go and take care of. I've been through some of the things Mr. Sonnabend was mentioning, too but I was able to fix most of them myself without coming up with it on this forum.


Return to “Installation”

Who is online

Users browsing this forum: No registered users and 2 guests