Installation of CE on Windows server

Problems with installing LogicalDOC? No problems, the solution is closer than you think.

Moderator: car031

sjropiak
Posts: 23
Joined: Wed Nov 09, 2011 1:59 pm

Installation of CE on Windows server

Mon Dec 05, 2011 2:08 pm

Is the installer for windows that you download for CE or is it just the paid versions? If not, are there detailed instructions to install from the Tomcat zip file? In particular, i need to know what the run.bat expects is installed Apache? IIS? MySQL? PHP?

Thanks
mmeschieri
Posts: 242
Joined: Mon Apr 19, 2010 3:40 pm

Re: Installation of CE on Windows server

Mon Dec 05, 2011 2:54 pm

For the tomcat bundle, just unpack and run. Once in execution you can launch the web setup from http://localhost:8080/setup
sjropiak
Posts: 23
Joined: Wed Nov 09, 2011 1:59 pm

Re: Installation of CE on Windows server

Mon Dec 05, 2011 8:02 pm

Thanks. i will do that.
sjropiak
Posts: 23
Joined: Wed Nov 09, 2011 1:59 pm

Re: Installation of CE on Windows server

Tue Dec 06, 2011 1:48 pm

So . . . I try to install the CE version on my Windows Server 2008 R2 and all I get for a result is this error:

"Neither the JAVA_HOME or JRE_HOME environment variable is defined
At least one of these environment variables is needed to run this program"

So, I ask again: "What software or packages need to be installed to run the CE version?" Based on that error, I'm thinking at least a Java development kit. What about MySQL? Does this batch file install the database too?

Thanks for your comments,

Steve
mmeschieri
Posts: 242
Joined: Mon Apr 19, 2010 3:40 pm

Re: Installation of CE on Windows server

Tue Dec 06, 2011 3:05 pm

You have to provide:
* a JDK 1.6.0+ and define the variable JAVA_HOME
* a running MySQL DBMS with an empty 'logicaldoc' database
sjropiak
Posts: 23
Joined: Wed Nov 09, 2011 1:59 pm

Re: Installation of CE on Windows server

Tue Dec 06, 2011 4:57 pm

Thank you. I will do that.
sjropiak
Posts: 23
Joined: Wed Nov 09, 2011 1:59 pm

Re: Installation of CE on Windows server

Tue Dec 06, 2011 8:24 pm

Is the installation process lengthy or is my server really slow? The script is at a point where it displays "- - -29 more". It took almost a half hour to get there and it sits there. I will let it run all evening if necessary, but am curious if this is normal or not.

Thanks,

Steve
mmeschieri
Posts: 242
Joined: Mon Apr 19, 2010 3:40 pm

Re: Installation of CE on Windows server

Tue Dec 06, 2011 9:13 pm

Absolutely not normal, the entire setup procedure is less than a minute.
sjropiak
Posts: 23
Joined: Wed Nov 09, 2011 1:59 pm

Re: Installation of CE on Windows server

Tue Dec 06, 2011 10:02 pm

Well, I am running it on my VM so maybe that slows it down. Two hours later it says 28 more. By Thursday . . . . . . Seriously, I will install on a real server.
mmeschieri
Posts: 242
Joined: Mon Apr 19, 2010 3:40 pm

Re: Installation of CE on Windows server

Wed Dec 07, 2011 7:35 am

Well we install every days on VMs and all is fast, so check your system and above all if you have free disk space.

Return to “Installation”

Who is online

Users browsing this forum: Google [Bot] and 3 guests