Migrating from 6.2.4 to 6.4

Problems with installing LogicalDOC? No problems, the solution is closer than you think.

Moderator: car031

ncariaga
Posts: 5
Joined: Fri May 18, 2012 7:38 am

Migrating from 6.2.4 to 6.4

Fri May 18, 2012 7:42 am

I'm planning to upgrade my CE 6.2.4 to 6.4. Does it follow the same upgrade method as with other versions? If not, how can I upgrade from 6.2.4 to 6.4?


Thank you.
agaspa
Posts: 709
Joined: Tue Apr 20, 2010 8:24 am

Re: Migrating from 6.2.4 to 6.4

Mon May 21, 2012 8:36 am

Actually the upgrade procedure for LD CE covers only the upgrade from LD 6.2.x to the latest LD CE 6.3.x, while the commercial editions are fully upgradable.

You can find the zip file for this task in the tools section of logicaldoc on SourceForge.
http://sourceforge.net/projects/logicaldoc/files/tools/

Be aware to perform a complete backup of the document repository and of the database data.
After every upgrade please clean completely the cache of your browser before attempting to login
agaspa
Posts: 709
Joined: Tue Apr 20, 2010 8:24 am

Re: Migrating from 6.2.4 to 6.4

Mon May 21, 2012 11:06 am

Absolutely Yes,
but while for the commercial editions of the product the upgrade packages are released close to the full release,
updates for the community version follow a slower path
nccariaga
Posts: 2
Joined: Wed Jul 11, 2012 6:21 am

Re: Migrating from 6.2.4 to 6.4

Wed Jul 11, 2012 6:33 am

Hi,

I was able to upgrade the installation to 6.3.5 CE. My concern is that the PDF preview is no longer working. A message "The preview of Office documents is enabled only on the commercial editions of LogicalDoc". Just want to ask if this feature is really disabled on the LD 6.3.5 CE?


Thank you.
agaspa
Posts: 709
Joined: Tue Apr 20, 2010 8:24 am

Re: Migrating from 6.2.4 to 6.4

Mon Aug 13, 2012 2:49 pm

In LogicalDOC 6.3 the property for the preview of pdf document has been changed,
now you must install in your system the package named SWFTools 0.9.1
then you must add the property swftools.path

See the documentation
http://docs.logicaldoc.com/en/installat ... tools.html
mmussato
Posts: 2
Joined: Fri Aug 24, 2012 9:56 am

Re: Migrating from 6.2.4 to 6.4

Fri Aug 24, 2012 10:00 am

brhahlen wrote:Anyhow: since 6.5 is out now, what are the plans of upgrade scripts for that? Are there plans?
hi all. same situation here: upgrades from 6.3.5 to all later versions are not successful due to altered database.
http://sourceforge.net/projects/logicaldoc/files/tools/ doesn't seem to managed recently.

When (if at all) will there be an upgrade script 6.3.5 -> 6.4.X or even 6.5?

best, michael
agaspa
Posts: 709
Joined: Tue Apr 20, 2010 8:24 am

Re: Migrating from 6.2.4 to 6.4

Thu Sep 06, 2012 2:43 pm

Starting from today you can download an upgrade package that allows you
to manually upgrade your existing LD CE 6.3.5 to version 6.4.2

http://sourceforge.net/projects/logical ... p/download

Please note that this upgrade applies only to LogicalDOC Community edition, the commercial editions are already covered up to the latest release by the official support included in the license purchase.

Return to “Installation”

Who is online

Users browsing this forum: No registered users and 1 guest