LogicalDOC 6.4.1 Access Denied

Problems with installing LogicalDOC? No problems, the solution is closer than you think.

Moderator: car031

Posts: 3
Joined: Wed May 09, 2012 7:27 am

LogicalDOC 6.4.1 Access Denied

Thu May 31, 2012 5:28 am

Hi all,

Recently my company asks me to find any knowledge management system that can be installed into our server for our documentation storage and management purpose. So, in order to learn how to install LogicalDOC before installing it finally in the real server, I installed VMware which includes installation of CentOS linux.
After finished installing Linux, then , I installed logicaldoc-cross-platform installer into the Linux OS. All installation were succeed, but unfortunately, when I open localhost:8080/logicaldoc on Linux, the login screen come out but when I try to login using username: admin, password: admin, the login page reply, "Access Denied". Apart from that, below the login button, there something written, ".... unregistered" and "the application needs to be restarted".

Really hope anyone can help me with this problem cause there isn't much time for me to finish this research. Thank you sooo much for any reply :D
Posts: 709
Joined: Tue Apr 20, 2010 8:24 am

Re: LogicalDOC 6.4.1 Access Denied

Thu May 31, 2012 2:23 pm

Did you have MySQL already installed in your server?
In this MySQL have you created preventively a database schema named logicaldoc?
Which version of LogicalDOC are you trying to install?
You can access the system log in the folder repository/logs, the main log file is dms.log, from here you can see if your LogicalDOC connects to the database correctly.
If this is not so perhaps you must do:
1) create database schema "logicaldoc" in MySQL
2) perform a new initialization of the database (this phase will create the tables)
Posts: 3
Joined: Wed May 09, 2012 7:27 am

Re: LogicalDOC 6.4.1 Access Denied

Fri Jun 01, 2012 1:26 am

Thank you for ur reply~ :)
Actually I didn't try to install MySQL yet because when I started installing LogicalDOC, its says that it will create its own internal database,
therefore I assume the database will be created simultaneously after installing LogicalDOC..
I'm have now installed LogicalDOC 6.4.1- i think that is the latest one..
Based on what you said, maybe it is connected to the installation and creation of external MySQL database. So, I will try to install the database again later
Posts: 3
Joined: Wed May 09, 2012 7:27 am

Re: LogicalDOC 6.4.1 Access Denied

Thu Jun 07, 2012 5:48 am

the version of LogicalDOC I tried to install was 6.4.1.
Actually before installing logicaldoc using the cross platform installer, I already installed mysql server, client and developer in the CentOS system manually.
I even created the user and password in that database and create a database named LogicalDOC.
Then, I installed LogicalDOC. However, when I went through the application installation, there is no interface that asked for either external or
internal database installation. The installation just keep going with the internal database installation.
How i'm going to switch the repositories into the external database?
and after i've done the installation using internal database, the login output is still the same, 'Access denied' and below is written, 'Licensed to: unregistered',
and 'the application needs to be restarted'. :(
Posts: 154
Joined: Tue Apr 17, 2012 8:27 am

Re: LogicalDOC 6.4.1 Access Denied

Tue Jun 12, 2012 6:52 am

The warning messages you see below the login form are correct, what's strange it is the access denied. It seems you are not connected to a database.
Since you are using Linux i suggest you to run the web setup http://localhost:8080/setup (admin/admin to enter)

Here you can specify an empty and existing MySQL schema, this could be a possible connection URL: jdbc:mysql://localhost/logicaldoc

I suggest also to read the dedicated installation guide: http://docs.logicaldoc.com/en/installat ... -line.html

Return to “Installation”

Who is online

Users browsing this forum: No registered users and 1 guest