System Requirements for LogicalDoc Community Edition

Problems with installing LogicalDOC? No problems, the solution is closer than you think.

Moderator: car031

agaspa
Posts: 709
Joined: Tue Apr 20, 2010 8:24 am

Re: System Requirements for LogicalDoc Community Edition

Thu Sep 06, 2012 2:51 pm

Tomcat is a servlet and jsp engine and it's required as it is needed in order to run LogicalDOC.
MySQL is the database engine that is recommended for production use.
Also you need Java JDK in order to run Tomcat and LogicalDOC.
LogicalDOC CE can run on any Linux server with at least 2GB of RAM.

Basically you can go with just 900 MB of RAM assigned to Tomcat,
but for best results you should assign more memory to Tomcat, on a JVM 32 bit you can assign up to 1500MB, with a 64bit server you can go up to 3GB of memory assigned to Tomcat.

Obviously it makes sense to increase the memory to Tomcat only if the number of documents, concurrent operations and users is high, otherwise you can go with the default settings.
CarlosValle
Posts: 1
Joined: Thu Nov 08, 2012 10:11 pm

Re: System Requirements for LogicalDoc Community Edition

Fri Nov 09, 2012 6:18 pm

Good Morning
Thank's for the info
I have a question, with the logicaldoc CE how I can increase the memory for the application?

I put 4Gb of info on the sofware, and I have many "out of memory" messages.

thank´s in advance!

My servers is whit windows 2003 Server, and we have 8GB of ram.

Carlos.

Return to “Installation”

Who is online

Users browsing this forum: No registered users and 1 guest