logicaldoc + linux, permission denied

Problems with installing LogicalDOC? No problems, the solution is closer than you think.

Moderator: car031

Posts: 2
Joined: Sun Sep 08, 2013 8:07 am

logicaldoc + linux, permission denied

Sun Sep 08, 2013 8:27 am

Hi, I would really like to see this working..
my log shows this, so definitely /logicaldoc is not enabled

8-Sep-2013 2:43:01 AM org.apache.catalina.core.ContainerBase addChildInternal
SEVERE: ContainerBase.addChild: start:
org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost].StandardContext[/logicaldoc]]
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:152)
at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:812)

I extracted
d5727f976c3dd739ff44e1501f34dc49 logicaldoc-6.7.3-tomcat-bundle.zip

to /opt, used root account to
cd /opt/logicaldoc-6.7.3-tomcat-bundle/tomcat/bin
chmod +x *
./catalina.sh run
stopped it (ctl-c)
ran it again,

step 7 from the README.txt file has
7) Access the LogicalDOC login page opening a browser to

I tried http://localhost:8080 , as /logicaldoc is not available
Apparently no accounts work as defined in /opt/logicaldoc-6.7.3-tomcat-bundle/tomcat/conf/tomcat-users.xml when i tried one of the 3 login buttons(server status, manager app, host manager)
(tomcat, admin, role1)
(I also reran startup.sh and shutdown.sh a couple of times, and I still get no change)

The permission denied response I get is
"403 Access Denied

You are not authorized to view this page.

If you have already configured the Manager application to allow access and you have used your browsers back button, used a saved book-mark or similar then you may have triggered the cross-site request forgery (CSRF) protection that has been enabled for the HTML interface of the Manager application. You will need to reset this protection by returning to the main Manager page. Once you return to this page, you will be able to continue using the Manager appliction's HTML interface normally. If you continue to see this access denied message, check that you have the necessary permissions to access this application.

If you have not changed any configuration files, please examine the file conf/tomcat-users.xml in your installation. That file must contain the credentials to let you use this webapp.

I have ran many tomcat projects, so if there are nifty commands or docs I can look into, I would like to see what I can do..

Do you guys use logicaldoc on Linux?
Posts: 242
Joined: Mon Apr 19, 2010 3:40 pm

Re: logicaldoc + linux, permission denied

Mon Sep 09, 2013 7:53 am

LogicalDOC runs very well on Linux.

You only have to downoad the .zip distribution and unpack it to have a ready to run Tomcat7 with LogicalDOC installed.
Remember to use Java7, the use of Java6

There is not need to access the Tomcat Manager nor to change the tomcat-users.xml

If you experience problems try to analyze the Catalina logs
Posts: 2
Joined: Sun Sep 08, 2013 8:07 am

Re: logicaldoc + linux, permission denied

Mon Sep 09, 2013 9:07 pm

i believe in my case JAVA_HOME was needed (was verifying the default java previously which appeared to the same parent path)
This tended to work for my case,
export JAVA_HOME=/opt/java-oracle/jdk1.7.0_25/
, session now in webbrowser :)

Return to “Installation”

Who is online

Users browsing this forum: No registered users and 1 guest