LogicalDOC 6.8.1 CE Edition Installation Issue SOLR

Problems with installing LogicalDOC? No problems, the solution is closer than you think.

Moderator: car031

oberoiro
Posts: 2
Joined: Tue Jan 14, 2014 3:27 am

LogicalDOC 6.8.1 CE Edition Installation Issue SOLR

Tue Jan 14, 2014 3:13 pm

Hi Guys,

I am new to LogicalDOC & just started with it. I recent downloaded the CE 6.8.1 version and complied against JDK 1.6. On successful compilation, I deployed the generated war to tomcat server and get following error during start up.

13.01.2014 21:21:50,231 INFO (org.apache.solr.schema.IndexSchema: 413) -- Reading Solr Schema
13.01.2014 21:21:50,248 ERROR (org.apache.solr.core.Config: 176) -- Exception during parsing file: schema:org.xml.sax.SAXParseException: Premature end of file.
at org.apache.xerces.util.ErrorHandlerWrapper.createSAXParseException(Unknown Source)

.....
.....

13.01.2014 21:21:50,255 ERROR (org.apache.solr.core.CoreContainer: 161) -- org.apache.solr.common.SolrException: Schema Parsing Failed: Premature end of file.
at org.apache.solr.schema.IndexSchema.readSchema(IndexSchema.java:688)
at org.apache.solr.schema.IndexSchema.<init>(IndexSchema.java:123)


Could someone advice what could be wrong?
mmeschieri
Posts: 242
Joined: Mon Apr 19, 2010 3:40 pm

Re: LogicalDOC 6.8.1 CE Edition Installation Issue SOLR

Wed Jan 15, 2014 8:32 am

LogicalDOC 6.8.1 needs to be compiled and executed with Java 1.7
agaspa
Posts: 709
Joined: Tue Apr 20, 2010 8:24 am

Re: LogicalDOC 6.8.1 CE Edition Installation Issue SOLR

Wed Jan 15, 2014 11:30 am

Yes it's true,
you may even be able to compile it, but since we started using the features of Java SE 7,
you may then find yourself with other errors at runtime that are difficult to resolve.
oberoiro
Posts: 2
Joined: Tue Jan 14, 2014 3:27 am

Re: LogicalDOC 6.8.1 CE Edition Installation Issue SOLR

Wed Jan 15, 2014 10:10 pm

Thxs Guys for the response. Is there a version which is compatible for java 1.6?
agaspa
Posts: 709
Joined: Tue Apr 20, 2010 8:24 am

Re: LogicalDOC 6.8.1 CE Edition Installation Issue SOLR

Thu Jan 16, 2014 9:58 am

I think that LD version 6.6.x is compatible with Java SE 6,
but honestly I would not recommend you use that,
instead try to install on your server a more recent version of Java.

I'm giving this advice because version 6.8.1 has better support for most modern browsers,
and since the interface of LD is built with JavaScript it is important to stay up to date with respect to the browser on the market.

Return to “Installation”

Who is online

Users browsing this forum: No registered users and 1 guest