Web Installer Broken

Problems with installing LogicalDOC? No problems, the solution is closer than you think.

Moderator: car031

KirbyTheG
Posts: 1
Joined: Fri Nov 24, 2017 11:47 pm

Web Installer Broken

Fri Nov 24, 2017 11:56 pm

Installer: logicaldoc-webinstaller-7.7.2.exe
Java Version: 1.8.0_151-b12
OS: Windows 10 64 bit

When I run the installer, it downloads the base install and then fails when executing the unpacked file. It incorrectly appends the path of the location of the installer exe to the beginning of the file.

So, when the installer copied to and run from c:\, and the install path is "/LogicalDOC", the error message says that this file is bad:

ERROR. C:\file:\C:\LogicalDOC\Uninstaller\IzpackWebTemp\izpacktempfile1351839746760482878jar (The filename, directory name, or volume label is incorrect)

If the installer is run from desktop, it give this error:

ERROR. C:\Users\MyUserName\Desktop\file:\C:\LogicalDOC\Uninstaller\IzpackWebTemp\izpacktempfile1351839746760482878jar

You can see that it is appending the location of the installer file to the path, which causes failure. Using a drive letter or other path ("c:\LogicalDOC") fails the same way.

The full java error is:

com.izforge.izpack.api.exception.ResourceException: Failed to read pack
in java.lang.Thread.run() at null:-1
in com.izforge.izpack.installer.unpacker.UnpackerBase.run() at UnpackerBase.java:236
in com.izforge.izpack.installer.unpacker.UnpackerBase.unpack() at UnpackerBase.java:251
in com.izforge.izpack.installer.unpacker.UnpackerBase.unpack() at UnpackerBase.java:430
in com.izforge.izpack.installer.unpacker.UnpackerBase.unpack() at UnpackerBase.java:468
in com.izforge.izpack.installer.unpacker.AbstractPackResources.getPackStream() at AbstractPackResources.java:85
in com.izforge.izpack.installer.unpacker.GUIPackResources.getWebPackStream() at GUIPackResources.java:84
Caused by: java.io.FileNotFoundException: C:\file:\C:\LogicalDOC\Uninstaller\IzpackWebTemp\izpacktempfile1351839746760482878jar (The filename, directory name, or volume label syntax is incorrect)
in com.izforge.izpack.installer.unpacker.GUIPackResources.getWebPackStream() at GUIPackResources.java:82
in java.net.URL.openStream() at null:-1
in sun.net.www.protocol.jar.JarURLConnection.getInputStream() at null:-1
in sun.net.www.protocol.jar.JarURLConnection.connect() at null:-1
in sun.net.www.protocol.jar.JarFileFactory.get() at null:-1
in sun.net.www.protocol.jar.URLJarFile.getJarFile() at null:-1
in sun.net.www.protocol.jar.URLJarFile. () at null:-1
in java.util.jar.JarFile. () at null:-1
in java.util.jar.JarFile. () at null:-1
in java.util.zip.ZipFile. () at null:-1
in java.util.zip.ZipFile. () at null:-1
in java.util.zip.ZipFile.open() at null:-2


Running the full installer works just fine.
admin
Site Admin
Posts: 14
Joined: Mon Apr 19, 2010 2:20 pm

Re: Web Installer Broken

Thu Nov 30, 2017 11:34 am

Thanks Kirby for reporting,
I created a task on the bug tracker in order to check it
Here is the link, if you want to follow it https://bugs.logicaldoc.com/ticket/840

Return to “Installation”

Who is online

Users browsing this forum: No registered users and 2 guests