Page 1 of 1

Wordpress Plugin Issue

Posted: Thu Feb 22, 2018 4:07 pm
by JoshFromDallas
I am trying to get the wordpress plugin to work. I just get a blank page. I had trouble getting the js scripts to load also but I ended up injecting them to test and still no luck getting it to load. Just wondering if anyone has any suggestions.

Logical Doc Version: Community 7.7.1
LogicalDoc Wordpress Epxlorer Version 1.0.3
Wordpress Version 4.9.4

Thanks for any suggestions,

Re: Wordpress Plugin Issue

Posted: Fri Feb 23, 2018 9:52 am
by shatzing
Hi Josh,
that plugin as of today (version 1.0.3) is compatible with LogicalDOC 7.5.3 and WordPress 4.7.9

I'm quite sure there are various compatibility issues based on your configuration data :?

I think that a new revision is planned, but I don't know exactly if a release date has been decided,
perhaps you can fill-out a feature request in the bug tracker and speed-up the process

Re: Wordpress Plugin Issue

Posted: Wed Apr 04, 2018 10:19 am
by shatzing
Hi Josh,
returning on a not too old Wordpress installation: 4.8.6, I verified that the LogicalDOC plugin was not working and rummaging through the middle of your the Apache error logs I found the following error:

PHP Fatal error: Uncaught Error: Class 'SoapClient' not found

PHP-SoapClient-error.png (30.19 KiB) Viewed 1400 times

I think it happened when I upgraded the server PHP from version 5.6 to 7.0
So due to this error the LogicalDOC plugin was not working at all, it was not even able to make the connection test to the remote server

After installing the soap module for PHP everything was solved and I could ascertain that the plugin works with LogicalDOC 7.7.5 and Wordpress 4.8.6

Below I'm reporting the instructions I ran on the Ubuntu 16.04 server

Code: Select all

apt-get install php7.0-soap
service apache2 restart