LogicalDOC community edition error

Problems with installing LogicalDOC? No problems, the solution is closer than you think.

Moderator: car031

ericmyat19
Posts: 1
Joined: Tue Jul 31, 2018 8:55 am

LogicalDOC community edition error

Tue Jul 31, 2018 9:26 am

I have done everything up to the " Install the parent dependencies" section, but encountered this error in my command line while following the guide (https://wiki.logicaldoc.com/wiki/Building_from_sources). Any help would be appreciated!

[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO]
[INFO] logicaldoc 7.7.6 ................................... SUCCESS [ 0.496 s]
[INFO] logicaldoc-util .................................... SUCCESS [05:33 min]
[INFO] logicaldoc-i18n .................................... SUCCESS [ 2.007 s]
[INFO] logicaldoc-core .................................... FAILURE [05:14 min]
[INFO] logicaldoc-webservice .............................. SKIPPED
[INFO] logicaldoc-webservicedoc ........................... SKIPPED
[INFO] logicaldoc-webdav .................................. SKIPPED
[INFO] logicaldoc-cmis .................................... SKIPPED
[INFO] logicaldoc-gui ..................................... SKIPPED
[INFO] logicaldoc-dropbox ................................. SKIPPED
[INFO] logicaldoc-webapp .................................. SKIPPED
[INFO] logicaldoc-benchmark ............................... SKIPPED
[INFO] logicaldoc-webservicesamples 7.7.6 ................. SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 10:53 min
[INFO] Finished at: 2018-07-31T13:49:58+06:30
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project logicaldoc-core: Could not resolve dependencies for project com.logicaldoc:logicaldoc-core:jar:7.7.6: The following artifacts could not be resolved: betelio:betelio:jar:1.0, javax.media:jai-core:jar:1.1.3: Could not transfer artifact betelio:betelio:jar:1.0 from/to logicaldoc (http://logicaldoc.sourceforge.net/maven): Connect to logicaldoc.sourceforge.net:80 [logicaldoc.sourceforge.net/216.105.38.10] failed: Connection timed out: connect -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/disp ... nException
[ERROR]
[ERROR] After correcting the problems, you can resume the build with the command
[ERROR] mvn <goals> -rf :logicaldoc-c
agaspa
Posts: 601
Joined: Tue Apr 20, 2010 8:24 am

Re: LogicalDOC community edition error

Wed Aug 01, 2018 4:24 pm

Hi ericmyat19,
the artifacts on which the error originated are correctly published on SourceForge.

http://logicaldoc.sourceforge.net/maven ... telio/1.0/
http://logicaldoc.sourceforge.net/maven ... /jai-core/

So perhaps it was a temporary network problem or an issue in SF, I don't know...
I suggest you try the process again

Return to “Installation”

Who is online

Users browsing this forum: No registered users and 1 guest