Search Indexing Optimization

LogicalDOC has many interesting features, but requires some configuration process to show its full potential.

Moderator: car031

OSUTyler
Contact:
Location: Columbus, OH
Posts: 1
Joined: Wed Nov 29, 2017 2:07 pm

Search Indexing Optimization

Wed Nov 07, 2018 3:43 pm

How do I configure the Enterprise Edition of LogicalDOC (7.7.2) so the search indexing happens more reliably?

Our users are adding lots of files but the "Documents Indexing" scheduled task does not seem to get very far.

The log file has a lot of these messages:

Code: Select all

07.11.2018 08:20:16,863 INFO   (com.logicaldoc.core.searchengine.IndexerTask:  76) -- Start indexing of all documents
07.11.2018 08:20:16,940 INFO   (com.logicaldoc.core.searchengine.IndexerTask: 102) -- Found a total of 500 documents to be processed
07.11.2018 08:20:16,986 INFO   (com.logicaldoc.core.searchengine.IndexerTask: 114) -- Documents marked for indexing in transaction 998a0700-0d6f-4071-a2b7-31ec9f653be5
07.11.2018 08:21:14,489 INFO   (com.logicaldoc.core.searchengine.IndexerTask: 125) -- Execution paused because of system overload
07.11.2018 08:22:35,603 INFO   (com.logicaldoc.core.searchengine.IndexerTask: 138) -- Execution resumed after system overload
07.11.2018 08:24:36,281 INFO   (com.logicaldoc.core.searchengine.IndexerTask: 125) -- Execution paused because of system overload
07.11.2018 08:26:24,315 INFO   (com.logicaldoc.core.searchengine.IndexerTask: 138) -- Execution resumed after system overload
07.11.2018 08:28:24,509 INFO   (com.logicaldoc.core.searchengine.IndexerTask: 125) -- Execution paused because of system overload
07.11.2018 08:29:26,546 INFO   (com.logicaldoc.core.searchengine.IndexerTask: 138) -- Execution resumed after system overload
07.11.2018 08:31:26,764 INFO   (com.logicaldoc.core.searchengine.IndexerTask: 125) -- Execution paused because of system overload
07.11.2018 08:32:29,029 INFO   (com.logicaldoc.core.searchengine.IndexerTask: 138) -- Execution resumed after system overload
07.11.2018 08:32:56,734 INFO   (com.logicaldoc.core.searchengine.IndexerTask: 125) -- Execution paused because of system overload
07.11.2018 08:33:08,982 INFO   (com.logicaldoc.core.searchengine.IndexerTask: 138) -- Execution resumed after system overload
07.11.2018 08:35:09,303 INFO   (com.logicaldoc.core.searchengine.IndexerTask: 125) -- Execution paused because of system overload
07.11.2018 08:36:15,340 INFO   (com.logicaldoc.core.searchengine.IndexerTask: 138) -- Execution resumed after system overload
07.11.2018 08:38:16,070 INFO   (com.logicaldoc.core.searchengine.IndexerTask: 125) -- Execution paused because of system overload
07.11.2018 08:39:21,115 INFO   (com.logicaldoc.core.searchengine.IndexerTask: 138) -- Execution resumed after system overload
07.11.2018 08:41:21,486 INFO   (com.logicaldoc.core.searchengine.IndexerTask: 125) -- Execution paused because of system overload
07.11.2018 08:42:14,545 INFO   (com.logicaldoc.core.searchengine.IndexerTask: 138) -- Execution resumed after system overload
07.11.2018 08:44:14,882 INFO   (com.logicaldoc.core.searchengine.IndexerTask: 125) -- Execution paused because of system overload
Our system has over 27,000 documents and is growing every day. Only 2500 are indexed leaving over 24,000 documents not indexed.

If Search is the most powerful feature of LogicalDOC, how do I give indexing prioritization so Search is effective?

Tyler
agaspa
Posts: 620
Joined: Tue Apr 20, 2010 8:24 am

Re: Search Indexing Optimization

Mon Nov 12, 2018 11:38 am

Hi Tyler,
I suggest you reduce the amount of documents to index to each batch.
The default is 500, but in your case it would probably be better 100
https://docs.logicaldoc.com/en/settings ... d-indexing
Just update the field: Batch

You can also increase the value of max CPU used by changing the parameters of the configuration.
https://docs.logicaldoc.com/en/settings/parameters
The parameter you can change is: load.cpumax

Return to “Configuration”

Who is online

Users browsing this forum: No registered users and 1 guest