not all uploaded documents are being processed

We tried to make LogicalDOC as intuitive as possible, but an advice is always welcome.

Moderator: car031

ShaharEldad
Posts: 24
Joined: Wed Nov 29, 2017 9:01 am

not all uploaded documents are being processed

Wed Jan 03, 2018 1:13 pm

Hi all

When I click the upload button I get a view to upload file.
When I click the button to open the file explorer to select files I select multiple files at once.
However, when I confirm my selection the system only process a single file, not all selected files.
You can see in the attached image what I mean (only one file has "done").
Is this a bug in the CE or a feature of the full application only?

Note: When I select multiple files one by one it is o.k.

Thanks for your help
Shahar
Attachments
Capture.JPG
select multiple files at once
Capture.JPG (39.69 KiB) Viewed 1374 times
shatzing
Posts: 79
Joined: Tue Jan 21, 2014 9:46 am

Re: not all uploaded documents are being processed

Tue Jan 09, 2018 12:05 pm

I think it's a small bug in the interface,
however it seems to me that all the added files are uploaded to the server when you click the "Send" button

What version of LogicalDOC are you trying?
What is the browser and its version?
ShaharEldad
Posts: 24
Joined: Wed Nov 29, 2017 9:01 am

Re: not all uploaded documents are being processed

Tue Jan 09, 2018 2:10 pm

shatzing wrote:
Tue Jan 09, 2018 12:05 pm
I think it's a small bug in the interface,
however it seems to me that all the added files are uploaded to the server when you click the "Send" button

What version of LogicalDOC are you trying?
What is the browser and its version?
The problem starts when I "save" the uploaded files with a document template and attribute sets. I get an error message for a duplicate key as in the attached image Capture1.jpg

I am using version 7.7.1 of theCommunity Edition.
My browser is chrome "Version 63.0.3239.132 (Official Build) (64-bit)"
Attachments
Capture1.JPG
error message for a duplicate key
Capture1.JPG (25.33 KiB) Viewed 1346 times
shatzing
Posts: 79
Joined: Tue Jan 21, 2014 9:46 am

Re: not all uploaded documents are being processed

Tue Jan 16, 2018 10:58 am

Hi Shahar,
which database are you using?

I have just reproduced the actions you have described on a new installation of LogicalDOC Community version 7.7.3 with MySQL database 5.7 https://hub.docker.com/r/logicaldoc/log ... -ce-mysql/

First I created a set of attributes, then I created a template and assigned the attribute set and finally I uploaded 7/8 documents at the same time assigning the specified template and populating the fields

Be aware that you should not populate the field "Custom ID" when you add the documents, otherwise you will get an SQL error because that is an SQL column with a unique constraint

Add-documents.png
Add documents - extended properties
Add-documents.png (24.54 KiB) Viewed 1299 times
ShaharEldad
Posts: 24
Joined: Wed Nov 29, 2017 9:01 am

Re: not all uploaded documents are being processed

Tue Jan 16, 2018 11:34 am

shatzing wrote:
Tue Jan 16, 2018 10:58 am
Hi Shahar,
which database are you using?

I have just reproduced the actions you have described on a new installation of LogicalDOC Community version 7.7.3 with MySQL database 5.7 https://hub.docker.com/r/logicaldoc/log ... -ce-mysql/

First I created a set of attributes, then I created a template and assigned the attribute set and finally I uploaded 7/8 documents at the same time assigning the specified template and populating the fields

Be aware that you should not populate the field "Custom ID" when you add the documents, otherwise you will get an SQL error because that is an SQL column with a unique constraint


Add-documents.png
Thanks, I understand
The error should be more clear as to the reason this happens - I`m still new to the code.
Do you have the option of fixing it or should I open a ticket somewhere for a fix?
shatzing
Posts: 79
Joined: Tue Jan 21, 2014 9:46 am

Re: not all uploaded documents are being processed

Fri Jan 19, 2018 9:25 am

Hi Shahar,
I don't think this is an error, but rather a feature of the software,
simply you should know that the field "Custom ID" is unique to the whole repository

So when you upload more than one document you should leave it empty.

Please note that by default that field replicates the ID of the document, but you can customize its schema.
The feature is called Custom Identifier (I don't remember if it is present in the community edition)
https://www.logicaldoc.com/software-fea ... identifier

That Custom ID might be auto-generated by the software and can be unique for a type of documents (Template)

Return to “Usage”

Who is online

Users browsing this forum: No registered users and 1 guest