Bugs found in webservice 7.7.1

Do you want to create a native client or integrate with third party applications: webservices are the solution.

Moderator: car031

kaiyuen4
Posts: 1
Joined: Tue May 28, 2019 11:32 pm

Bugs found in webservice 7.7.1

Wed May 29, 2019 12:03 am

I don't know if any one will reply or seeing this post.

I am making my logical system base on webservice in 7.7.1 but faced quite a lot of bugs on web service call.

1. One error message keeps prompting from time to time in logical server log when I am doing the load test.

=====================================================================================
(com.logicaldoc.web.service.FolderServiceImpl:1000) -- failed to lazily initialize a collection of role: com.logicaldoc.core.folder.Folder.attributes, could not initialize proxy - no Session

com.logicaldoc.web.service.FolderServiceImpl.prepareGUIAttributes(FolderServiceImpl.java:985)
com.logicaldoc.web.service.FolderServiceImpl.fromFolder(FolderServiceImpl.java:185)
=====================================================================================

The lazy load is changed in Folder.hbm.xml from true to false
=====================================================================================
<map name="attributes" table="ld_folder_ext" lazy="true" cascade="all" order-by="ld_position asc">
=====================================================================================
This causes more IO on DB and processing time was increased.

And I still can't solve it now

2.
Bugs when updating document properties, the language fields was wrongly placed in another filed.
And I have fixed this bug on my own for 3 days just to search which line of code.

3.
The full text search is not fully integrated with ld_foldergroup which causing N+1 problem
For example, I need to search document through full text and have the search result with LD_Docuemnt.Ld_id
Then, I need to use the document list to join the ld_folder and ld_foldergroup



Any support teams member see this post, feel free to contact me.
agaspa
Posts: 681
Joined: Tue Apr 20, 2010 8:24 am

Re: Bugs found in webservice 7.7.1

Thu Jun 06, 2019 1:11 pm

Hi @kaiyuen4,
version 7.7.1 is quite outdated and no more supported.
I suggest you to upgrade to a more recent version of LogicalDOC CE (latest release is 8.3)

For more information
Migrate from LDCE7.7 to LDCE8.1?
Upgrade from 7.7.3 to vs 8.2.1
Upgrade CE 8.1 to 8.3

Return to “Web Services”

Who is online

Users browsing this forum: No registered users and 2 guests