Question marks on non English characters

We tried to make LogicalDOC as intuitive as possible, but an advice is always welcome.

Moderator: car031

maznick
Posts: 3
Joined: Fri Dec 21, 2018 3:17 pm

Question marks on non English characters

Fri Dec 21, 2018 8:23 pm

I am trying to store Greek characters in a custom attribute of a document and the characters replaced by question marks. The mysql database is in utf8 encoding and as I saw it has the question marks in the table's field value but I can replace them to Greek in database.
Is there any setting I can use to fix this issue?
agaspa
Posts: 652
Joined: Tue Apr 20, 2010 8:24 am

Re: Question marks on non English characters

Thu Dec 27, 2018 5:52 pm

Hi maznick,
what is exactly the version of LogicalDOC you're using?
Does the problem occur both on the filename and the attributes or only on the attributes?
If it only occurs on the attributes you should try to check the properties of table ld_document_ext and the ld_stringvalue column
agaspa
Posts: 652
Joined: Tue Apr 20, 2010 8:24 am

Re: Question marks on non English characters

Thu Dec 27, 2018 5:57 pm

Here is a useful link:
https://stackoverflow.com/questions/104 ... -column-is

Here are some queries

For Table 'ld_document_ext':

Code: Select all

SELECT CCSA.character_set_name FROM information_schema.`TABLES` T,
       information_schema.`COLLATION_CHARACTER_SET_APPLICABILITY` CCSA
WHERE CCSA.collation_name = T.table_collation
  AND T.table_schema = "your-schema-name"
  AND T.table_name = "ld_document_ext";
For Column 'ld_stringvalue' :

Code: Select all

  SELECT character_set_name FROM information_schema.`COLUMNS` 
WHERE table_schema = "your-schema-name"
  AND table_name = "ld_document_ext"
  AND column_name = "ld_stringvalue"; 
maznick
Posts: 3
Joined: Fri Dec 21, 2018 3:17 pm

Re: Question marks on non English characters

Sat Dec 29, 2018 7:24 pm

Hi agaspa,
I am using the latest veraion 8.1.1 and all the fields in mysql database are in utf8-bin collation and when I update the fields from database values are stored in Greek. So I don't think the problem is from database. Do you have any idea about that?
maznick
Posts: 3
Joined: Fri Dec 21, 2018 3:17 pm

Re: Question marks on non English characters

Thu Jan 03, 2019 8:34 am

Hi Agaspa,
I tried the queries you sent me and the response is utf8.
I also tried to use Greek characters in other fields and in all I receive the same result all the characters are changed to "?".
I have also attached and a screenshot of the problem.
Can you please help me.
Attachments
logicaldoc_sshot.png
logicaldoc_sshot.png (27.42 KiB) Viewed 108 times

Return to “Usage”

Who is online

Users browsing this forum: No registered users and 1 guest